Update

We are working around the clock to find a quick solution to restore access to all systems.
The web servers are back online.
Teamspeak Cloud is currently starting up.
Posted Aug 05, 2026 - 13:20 CEST

Identified

We have the issue identified. We actually in restore process, please wait until we can make a update
Posted Aug 05, 2026 - 09:15 CEST

Investigating

Our entire VMware virtualization cluster is currently experiencing an outage; we are currently investigating the cause.
Posted Aug 05, 2026 - 04:31 CEST
This incident affects: Infrastructure (Tower), Cloud Infrastructure, and Infrastructure (Rackserver).